summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-09-07 16:15:08 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-09-07 23:44:01 -0700
commit68fea604b06a6d1d461fa856a6379bb49500fb3b (patch)
treeb124fb00c902537d1b3e63ac4f721ced4f826fa4 /gnu/packages/image.scm
parent37ecf2d905e6afc555150ffe51095415a0d27b89 (diff)
downloadguix-patches-68fea604b06a6d1d461fa856a6379bb49500fb3b.tar
guix-patches-68fea604b06a6d1d461fa856a6379bb49500fb3b.tar.gz
gnu: Add pngsuite.
* gnu/packages/image (pngsuite): New variable.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 4e3fee53e2..433e59c207 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1462,6 +1462,40 @@ PNG, and performs PNG integrity checks and corrections.")
(home-page "http://optipng.sourceforge.net/")
(license license:zlib)))
+(define-public pngsuite
+ (package
+ (name "pngsuite")
+ (version "2017jul19")
+ (source
+ (origin
+ (method url-fetch/tarbomb)
+ (uri (string-append "http://www.schaik.com/pngsuite2011/PngSuite-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "1j7xgd9iffcnpphhzz9ld9ybrjmx9brhq0803g0450ssr52b5502"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; there is no test target
+ #:license-file-regexp "PngSuite.LICENSE"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (copy-recursively "." (string-append out "/"))
+ #t)))
+ (delete 'build)
+ (delete 'configure))))
+ (home-page "http://www.schaik.com/pngsuite2011/pngsuite.html")
+ (synopsis "Example PNGs for use in test suites")
+ (description "Collection of graphics images created to test PNG
+applications like viewers, converters and editors. As far as that is
+possible, all formats supported by the PNG standard are represented.")
+ (license (license:fsdg-compatible "file://PngSuite.LICENSE" "Permission to
+use, copy, modify and distribute these images for any purpose and without fee
+is hereby granted."))))
+
(define-public libjpeg-turbo
(package
(name "libjpeg-turbo")