summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 22:06:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-24 13:46:38 +0100
commite2f47efee62010f6382fa5a4c43c6eb1b3c3d365 (patch)
treef839d12f093454fdc27dbcc317e90be062d82d0d /gnu/packages/image-viewers.scm
parentd39a54ff725867a76afb4e66b7cb4f279e0077c4 (diff)
downloadguix-patches-e2f47efee62010f6382fa5a4c43c6eb1b3c3d365.tar
guix-patches-e2f47efee62010f6382fa5a4c43c6eb1b3c3d365.tar.gz
gnu: catimg: Simplify.
* gnu/packages/image-viewers.scm (catimg)[arguments]: Rename custom "configure" phase to "patch-convert"; remove custom "build" phase; move "install-script" phase after "install"; simplify phases.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm39
1 files changed, 13 insertions, 26 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 4188ff2f15..895802cc94 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -301,37 +301,24 @@ your images. Among its features are:
`(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((magic (assoc-ref %build-inputs "imagemagick"))
- (convert (string-append magic "/bin/convert")))
- (substitute* "catimg"
- ;; By replacing "convert", we also replace the "convert"
- ;; in the message 'The version of convert is too old, don't
- ;; expect good results :('. This should not happen, but in
- ;; practice this error message should not affect us.
- (("convert") convert))
- #t)))
- (replace 'build
+ (add-after 'unpack 'patch-convert
(lambda _
- (let* ((out (assoc-ref %outputs "out"))
- (man (string-append out "/share/man/man1")))
- (zero? (system* "cmake"
- (string-append "-DCMAKE_INSTALL_PREFIX=" out)
- (string-append "-DMAN_OUTPUT_PATH=" man)
- "."))
- (zero? (system* "make")))))
- (add-before 'install 'install-script
+ (substitute* "catimg"
+ ;; By replacing "convert", we also replace the "convert"
+ ;; in the message 'The version of convert is too old, don't
+ ;; expect good results :('. This should not happen, but in
+ ;; practice this error message should not affect us.
+ (("convert") (which "convert")))
+ #t))
+ (add-after 'install 'install-script
(lambda* (#:key outputs #:allow-other-keys)
;; The bash script lacks an file extension. We have to rename
;; it so that the C program and the bash script can be happy
;; side by side.
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (install-file "catimg" bin)
- (rename-file (string-append bin "/catimg")
- (string-append bin "/catimg.sh"))
- #t))))))
+ (copy-file "../source/catimg"
+ (string-append (assoc-ref outputs "out")
+ "/bin/catimg.sh"))
+ #t)))))
(inputs
`(("imagemagick" ,imagemagick))) ; for the bash script version
(home-page "https://github.com/posva/catimg")