summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-17 14:21:33 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-17 14:22:08 +0100
commit51c8777095ee8863943432cc71a63b6fa6c5b8c0 (patch)
tree3d2eb06d5cbf1c63a03b72d6c697b0563542a496 /gnu/packages/image-viewers.scm
parentcd819b45e9ba4c1d56355f26c1ee7529e543e23f (diff)
downloadguix-patches-51c8777095ee8863943432cc71a63b6fa6c5b8c0.tar
guix-patches-51c8777095ee8863943432cc71a63b6fa6c5b8c0.tar.gz
gnu: imv: Record the absolute file name of 'imv-x11' and 'imv-wayland'.
* gnu/packages/image-viewers.scm (imv)[arguments]: Add 'record-absolute-file-names' phase.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 9397322e96..935cecd93c 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -548,7 +548,17 @@ displayed in a terminal.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (delete 'configure))
+ (delete 'configure)
+ (add-after 'install 'record-absolute-file-names
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; 'imv' is a script that execs 'imv-x11' or 'imv-wayland'.
+ ;; Record their absolute file name.
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (substitute* (string-append bin "/imv")
+ (("imv-")
+ (string-append bin "/imv-")))
+ #t))))
#:make-flags
(list "CC=gcc"
(string-append "PREFIX=" (assoc-ref %outputs "out"))