summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorPeng Mei Yu <pengmeiyu@riseup.net>2020-01-07 18:18:00 +0800
committerLudovic Courtès <ludo@gnu.org>2020-01-17 14:22:08 +0100
commitcd819b45e9ba4c1d56355f26c1ee7529e543e23f (patch)
tree4eac73c2465d3bcae6adc7bcba01b410b689ef13 /gnu/packages/image-viewers.scm
parent57b6caefc2ad60fc9c2e61750740e1b1c455f8e2 (diff)
downloadguix-patches-cd819b45e9ba4c1d56355f26c1ee7529e543e23f.tar
guix-patches-cd819b45e9ba4c1d56355f26c1ee7529e543e23f.tar.gz
gnu: Add imv.
* gnu/packages/image-viewers.scm (imv): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index eef2866b4b..9397322e96 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,11 +41,15 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages algebra)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
@@ -59,6 +64,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
#:use-module (gnu packages))
@@ -524,3 +530,59 @@ including animated GIFs, into ANSI/Unicode character output that can be
displayed in a terminal.")
(home-page "https://hpjansson.org/chafa/")
(license license:lgpl3+)))
+
+(define-public imv
+ (package
+ (name "imv")
+ (version "4.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eXeC64/imv")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0gk8g178i961nn3bls75a8qpv6wvfvav6hd9lxca1skaikd33zdx"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure))
+ #:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CONFIGPREFIX="
+ (assoc-ref %outputs "out") "/etc"))))
+ (inputs
+ `(("asciidoc" ,asciidoc)
+ ("freeimage" ,freeimage)
+ ("glu" ,glu)
+ ("librsvg" ,librsvg)
+ ("libxkbcommon" ,libxkbcommon)
+ ("pango" ,pango)
+ ("wayland" ,wayland)))
+ (native-inputs
+ `(("cmocka" ,cmocka)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Image viewer for tiling window managers")
+ (description "@code{imv} is a command line image viewer intended for use
+with tiling window managers. Features include:
+
+@itemize
+@item Native Wayland and X11 support.
+@item Support for dozens of image formats including:
+@itemize
+@item PNG
+@item JPEG
+@item Animated GIFs
+@item SVG
+@item TIFF
+@item Various RAW formats
+@item Photoshop PSD files
+@end itemize
+@item Configurable key bindings and behavior.
+@item Highly scriptable with IPC via imv-msg.
+@end itemize\n")
+ (home-page "https://github.com/eXeC64/imv")
+ (license license:expat)))