summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-08 15:35:58 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-11 21:01:10 +0200
commitdf0010a9dc18937ba481393f9d153a476dac13c0 (patch)
tree8c06da584323597df2aceb2f8eb1a115b8a42fae /gnu/packages/hurd.scm
parentda987ece8f9a4ecb6d1d40b042da2c829367f059 (diff)
downloadguix-patches-df0010a9dc18937ba481393f9d153a476dac13c0.tar
guix-patches-df0010a9dc18937ba481393f9d153a476dac13c0.tar.gz
gnu: hurd: "/libexec/rc" spawns the console client.
* gnu/packages/hurd.scm (hurd-rc-script): Start the console client.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index f7c0637f40..90e39a279b 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -341,7 +341,12 @@ boot, since this cannot be done from GNU/Linux."
(unless (translated? node)
(mkdir-p (dirname node))
(apply invoke "settrans" "-c" node command))))
- '#$translators))))
+ '#$translators)
+
+ ;; Start the oh-so-fancy console client.
+ (mkdir-p "/var/run") ;for the PID file
+ (invoke "console" "--daemonize" "-c" "/dev/vcs"
+ "-d" "vga" "-d" "pc_kbd" "-d" "generic_speaker"))))
;; FIXME: We want the program to use the cross-compiled Guile when
;; cross-compiling. But why do we need to be explicit here?