summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/hurd.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index f7c0637f40..90e39a279b 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -341,7 +341,12 @@ boot, since this cannot be done from GNU/Linux."
(unless (translated? node)
(mkdir-p (dirname node))
(apply invoke "settrans" "-c" node command))))
- '#$translators))))
+ '#$translators)
+
+ ;; Start the oh-so-fancy console client.
+ (mkdir-p "/var/run") ;for the PID file
+ (invoke "console" "--daemonize" "-c" "/dev/vcs"
+ "-d" "vga" "-d" "pc_kbd" "-d" "generic_speaker"))))
;; FIXME: We want the program to use the cross-compiled Guile when
;; cross-compiling. But why do we need to be explicit here?