summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:30:37 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitfcacbec34ecd65d9a770e502295e406193abb526 (patch)
tree7afb20a7903c1f4f1e4c9641e84209456f35a9eb /gnu/packages/haskell.scm
parent132133c1ae11479853752de69e46bd0a2451b837 (diff)
downloadguix-patches-fcacbec34ecd65d9a770e502295e406193abb526.tar
guix-patches-fcacbec34ecd65d9a770e502295e406193abb526.tar.gz
gnu: Add ghc-filemanip.
* gnu/packages/haskell.scm (ghc-filemanip): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0978b2afcd..9b99addcb6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5503,6 +5503,29 @@ back-ends.")
"This package provides a library to parse and render YAML documents.")
(license bsd-3)))
+(define-public ghc-filemanip
+ (package
+ (name "ghc-filemanip")
+ (version "0.3.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "filemanip/filemanip-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ilqr8jv41zxcj5qyicg29m8s30b9v70x6f9h2h2rw5ap8bxldl8"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-unix-compat" ,ghc-unix-compat)))
+ (home-page "https://github.com/bos/filemanip")
+ (synopsis "File and directory manipulation for Haskell")
+ (description
+ "This package provides a Haskell library for working with files and
+directories. It includes code for pattern matching, finding files, modifying
+file contents, and more.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")