summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:30:17 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit132133c1ae11479853752de69e46bd0a2451b837 (patch)
tree405dda5fdf5db32b31f9bfae4c87f75d6ec64304 /gnu/packages/haskell.scm
parent9efdbb72afc1ce0d84eef777857715e1b3d253c0 (diff)
downloadguix-patches-132133c1ae11479853752de69e46bd0a2451b837.tar
guix-patches-132133c1ae11479853752de69e46bd0a2451b837.tar.gz
gnu: Add ghc-yaml.
* gnu/packages/haskell.scm (ghc-yaml): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e01c9c362b..0978b2afcd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5469,6 +5469,40 @@ back-ends.")
"The mockery package provides support functions for automated testing.")
(license expat)))
+(define-public ghc-yaml
+ (package
+ (name "ghc-yaml")
+ (version "0.8.15.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "yaml/yaml-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0v6c435xmgm99zxb30pqr7lhkb2a56wxqp70g4hjz8p7rj0vichx"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-conduit" ,ghc-conduit)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-text" ,ghc-text)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-enclosed-exceptions" ,ghc-enclosed-exceptions)
+ ("ghc-aeson-qq" ,ghc-aeson-qq)
+ ("ghc-base-compat" ,ghc-base-compat)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-mockery" ,ghc-mockery)))
+ (home-page "http://github.com/snoyberg/yaml/")
+ (synopsis "Parsing and rendering YAML documents")
+ (description
+ "This package provides a library to parse and render YAML documents.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")