summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:10:16 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitcb31771f8443efb09a47605a70fc8ac999aeb998 (patch)
tree22ab0bc9b50d3e5c8d6718511e407fe4c7b22e3c /gnu/packages/haskell.scm
parent3611fc7bffecc723c9d401fb5453c7f19e4be64e (diff)
downloadguix-patches-cb31771f8443efb09a47605a70fc8ac999aeb998.tar
guix-patches-cb31771f8443efb09a47605a70fc8ac999aeb998.tar.gz
gnu: Add ghc-aeson-qq.
* gnu/packages/haskell.scm (ghc-aeson-qq): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b3d533b366..7d1426c2cc 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5335,6 +5335,37 @@ package, and that's where the version number started.")
template-haskell abstract syntax.")
(license bsd-3)))
+(define-public ghc-aeson-qq
+ (package
+ (name "ghc-aeson-qq")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "aeson-qq/aeson-qq-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z8kh3qjc4khadz1ijdqm7fbk7dh17sisqhpwd3c9aibj2927k9d"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-text" ,ghc-text)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-haskell-src-meta" ,ghc-haskell-src-meta)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "http://github.com/zalora/aeson-qq")
+ (synopsis "JSON quasiquoter for Haskell")
+ (description
+ "aeson-qq provides a JSON quasiquoter for Haskell. This package exposes
+the function @code{aesonQQ} that compile-time converts a string representation
+of a JSON value into a @code{Data.Aeson.Value}.")
+ (license expat)))
+
(define-public idris
(package
(name "idris")