summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:09:52 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit3611fc7bffecc723c9d401fb5453c7f19e4be64e (patch)
tree4db5c38c6401a4ac9a3149701fed00a5adbee848 /gnu/packages/haskell.scm
parent2e6772515055d1e1fb4ad15356be20f61ebea631 (diff)
downloadguix-patches-3611fc7bffecc723c9d401fb5453c7f19e4be64e.tar
guix-patches-3611fc7bffecc723c9d401fb5453c7f19e4be64e.tar.gz
gnu: Add ghc-haskell-src-meta.
* gnu/packages/haskell.scm (ghc-haskell-src-meta): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 183033eb87..b3d533b366 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5311,6 +5311,30 @@ and @code{Eq} instances. These instances used to live in the haskell-src-meta
package, and that's where the version number started.")
(license bsd-3)))
+(define-public ghc-haskell-src-meta
+ (package
+ (name "ghc-haskell-src-meta")
+ (version "0.6.0.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "haskell-src-meta/haskell-src-meta-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1mzbfrfvl6pj8068w3m6alzry1403ir1gmz3czg66n5z198l4dql"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-th-orphans" ,ghc-th-orphans)))
+ (home-page "http://hackage.haskell.org/package/haskell-src-meta")
+ (synopsis "Parse source to template-haskell abstract syntax")
+ (description
+ "This package provides tools to parse Haskell sources to the
+template-haskell abstract syntax.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")