summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:04:19 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit8164d58ec730f060636af5397ab09199d37ec472 (patch)
tree64277538a18c78596dbfbd7fe514da987bf2ba06 /gnu/packages/haskell.scm
parent4cbd9f5993a71eb5586697ed5128f01e7580adf7 (diff)
downloadguix-patches-8164d58ec730f060636af5397ab09199d37ec472.tar
guix-patches-8164d58ec730f060636af5397ab09199d37ec472.tar.gz
gnu: Add ghc-pandoc-types.
* gnu/packages/haskell.scm (ghc-pandoc-types): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5ebc1f10aa..587250d8fe 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4974,6 +4974,31 @@ functionality.")
providing an 'rnf' implementation.")
(license bsd-3)))
+(define-public ghc-pandoc-types
+ (package
+ (name "ghc-pandoc-types")
+ (version "1.12.4.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "pandoc-types/pandoc-types-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "108n11kbdaj2ii3cyf0xczhsx90p1gjbxwqp1f0wyn2m3cls632n"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-syb" ,ghc-syb)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-deepseq-generics" ,ghc-deepseq-generics)))
+ (home-page "http://johnmacfarlane.net/pandoc")
+ (synopsis "Types for representing a structured document")
+ (description
+ "This module defines the @code{Pandoc} data structure, which is used by
+pandoc to represent structured documents. It also provides functions for
+building up, manipulating and serialising @code{Pandoc} structures.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")