summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:03:55 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit4cbd9f5993a71eb5586697ed5128f01e7580adf7 (patch)
tree0582de169078efeb139efd6da722dbe16547b072 /gnu/packages/haskell.scm
parent6ff4a50d75cd6acdc4e3dde72a398440dc76c717 (diff)
downloadguix-patches-4cbd9f5993a71eb5586697ed5128f01e7580adf7.tar
guix-patches-4cbd9f5993a71eb5586697ed5128f01e7580adf7.tar.gz
gnu: Add ghc-deepseq-generics.
* gnu/packages/haskell.scm (ghc-deepseq-generics): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7731e2447a..5ebc1f10aa 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4941,6 +4941,39 @@ communication between web applications and web servers.")
functionality.")
(license expat)))
+(define-public ghc-deepseq-generics
+ (package
+ (name "ghc-deepseq-generics")
+ (version "0.1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "deepseq-generics/deepseq-generics-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "01pvigx8n9p8hwbzp2qiq6kzf7cxiam843jz2sjgliacmmp1v7l3"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-ghc-prim-dependency
+ (lambda _
+ (substitute* "deepseq-generics.cabal"
+ (("< 0.4") "< 0.5"))
+ #t)))))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
+ (home-page "https://github.com/hvr/deepseq-generics")
+ (synopsis "Generic RNF implementation")
+ (description
+ "This package provides a @code{GHC.Generics}-based
+@code{Control.DeepSeq.Generics.genericRnf} function which can be used for
+providing an 'rnf' implementation.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")