summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:34:08 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit8078327341917f5ea4173ed77c00d6b7ba723154 (patch)
tree690f750947b48f92bd4da64c023fc4fc53073a0a /gnu/packages/haskell.scm
parentd4ce416a5cad2d0c63fe1e8209691f3830cc8462 (diff)
downloadguix-patches-8078327341917f5ea4173ed77c00d6b7ba723154.tar
guix-patches-8078327341917f5ea4173ed77c00d6b7ba723154.tar.gz
gnu: Add ghc-asn1-encoding.
* gnu/packages/haskell.scm (ghc-asn1-encoding): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 327e232882..282b6f62d0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5794,6 +5794,34 @@ Mail} (PEM) format.")
format.")
(license bsd-3)))
+(define-public ghc-asn1-encoding
+ (package
+ (name "ghc-asn1-encoding")
+ (version "0.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "asn1-encoding/asn1-encoding-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "01ki5msrpccgdbdiaaa5a9zw0icp1hki4hca8qx6hzlp0rcf1mwh"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-hourglass" ,ghc-hourglass)
+ ("ghc-asn1-types" ,ghc-asn1-types)
+ ("ghc-text" ,ghc-text)
+ ("ghc-mtl" ,ghc-mtl)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "http://github.com/vincenthz/hs-asn1")
+ (synopsis "ASN1 data reader and writer in RAW, BER and DER forms")
+ (description
+ "This package provides a reader and writer for ASN1 data in raw form with
+supports for high level forms of ASN1 (BER, and DER).")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")