summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:33:47 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitd4ce416a5cad2d0c63fe1e8209691f3830cc8462 (patch)
tree0aea63435077c53ba0a3d661b2a4a506f1f2fe25 /gnu/packages/haskell.scm
parented8924c0d7df9c8bd8c718d5c84ea7e72b610231 (diff)
downloadguix-patches-d4ce416a5cad2d0c63fe1e8209691f3830cc8462.tar
guix-patches-d4ce416a5cad2d0c63fe1e8209691f3830cc8462.tar.gz
gnu: Add ghc-asn1-types.
* gnu/packages/haskell.scm (ghc-asn1-types): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b7baf3f4ed..327e232882 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5771,6 +5771,29 @@ representations of current time.")
Mail} (PEM) format.")
(license bsd-3)))
+(define-public ghc-asn1-types
+ (package
+ (name "ghc-asn1-types")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "asn1-types/asn1-types-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1iif9yrh4mmj249gyvam0zb2vb3jnlz777gahh2z9sx00dsx9rja"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-memory" ,ghc-memory)
+ ("ghc-hourglass" ,ghc-hourglass)))
+ (home-page "http://github.com/vincenthz/hs-asn1-types")
+ (synopsis "ASN.1 types for Haskell")
+ (description
+ "The package provides the standard types for dealing with the ASN.1
+format.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")