summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-07-18 07:22:31 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:50 -0400
commit38dd4c1da55f7047d9307348c845a1677c3b51d4 (patch)
treecf80f6e7d77037e286867a62e4463a642d366f81 /gnu/packages/haskell.scm
parentef803cb520f73bf51fa653064e8310b4723f8447 (diff)
downloadguix-patches-38dd4c1da55f7047d9307348c845a1677c3b51d4.tar
guix-patches-38dd4c1da55f7047d9307348c845a1677c3b51d4.tar.gz
gnu: Add ghc-microlens-ghc.
* gnu/packages/haskell.scm (ghc-microlens-ghc): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d86173f697..a532f1595d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11880,6 +11880,32 @@ mtl package. This package is a part of the
readme @uref{https://github.com/aelve/microlens#readme, on Github}.")
(license license:bsd-3)))
+(define-public ghc-microlens-ghc
+ (package
+ (name "ghc-microlens-ghc")
+ (version "0.4.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/microlens-ghc/microlens-ghc-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "03iwgg8zww9irv59l70c8yy7vzxir1zf66y12210xk91k5hq6jrj"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-microlens" ,ghc-microlens)))
+ (home-page "https://github.com/monadfix/microlens")
+ (synopsis "Use @code{microlens} with GHC libraries like @code{array}")
+ (description "This library provides everything that @code{microlens}
+provides plus instances to make @code{each}, @code{at}, and @code{ix}
+usable with arrays, @code{ByteString}, and containers. This package is
+a part of the @uref{http://hackage.haskell.org/package/microlens,
+microlens} family; see the readme
+@uref{https://github.com/aelve/microlens#readme, on Github}.")
+ (license license:bsd-3)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")