summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-07-18 07:22:18 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:50 -0400
commitef803cb520f73bf51fa653064e8310b4723f8447 (patch)
tree3ca559a4d72a835eadcb3a2fd8959c6757f5662f /gnu/packages/haskell.scm
parent64b7c06e188c7d5a05a5d726eba0cf46698cb78e (diff)
downloadguix-patches-ef803cb520f73bf51fa653064e8310b4723f8447.tar
guix-patches-ef803cb520f73bf51fa653064e8310b4723f8447.tar.gz
gnu: Add ghc-microlens-mtl.
* gnu/packages/haskell.scm (ghc-microlens-mtl): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2e845d0e93..d86173f697 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11851,6 +11851,35 @@ provides a means to round-trip any code that can be compiled by GHC, currently
excluding @file{.lhs} files.")
(license license:bsd-3)))
+(define-public ghc-microlens-mtl
+ (package
+ (name "ghc-microlens-mtl")
+ (version "0.1.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/microlens-mtl/microlens-mtl-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0l6z1gkzwcpv89bxf5vgfrjb6gq2pj7sjjc53nvi5b9alx34zryk"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-microlens" ,ghc-microlens)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
+ (home-page "https://github.com/monadfix/microlens")
+ (synopsis
+ "@code{microlens} support for Reader/Writer/State from mtl")
+ (description
+ "This package contains functions (like @code{view} or @code{+=}) which
+work on @code{MonadReader}, @code{MonadWriter}, and @code{MonadState} from the
+mtl package. This package is a part of the
+@uref{http://hackage.haskell.org/package/microlens, microlens} family; see the
+readme @uref{https://github.com/aelve/microlens#readme, on Github}.")
+ (license license:bsd-3)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")