summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-07-18 07:22:47 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:50 -0400
commit37850fb9a0989d80c6e7375dd323b779cb619c16 (patch)
treeac42f9cdd64ee24e520bbddb3094aa6737d2f5db /gnu/packages/haskell.scm
parent38dd4c1da55f7047d9307348c845a1677c3b51d4 (diff)
downloadguix-patches-37850fb9a0989d80c6e7375dd323b779cb619c16.tar
guix-patches-37850fb9a0989d80c6e7375dd323b779cb619c16.tar.gz
gnu: Add ghc-microlens-platform.
* gnu/packages/haskell.scm (ghc-microlens-platform): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a532f1595d..1087461dac 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11906,6 +11906,49 @@ microlens} family; see the readme
@uref{https://github.com/aelve/microlens#readme, on Github}.")
(license license:bsd-3)))
+(define-public ghc-microlens-platform
+ (package
+ (name "ghc-microlens-platform")
+ (version "0.3.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/"
+ "microlens-platform/microlens-platform-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1d4nhmgf9jq0ixc7qhwm7aaw3xdr0nalw58d0ydsydgf02cyazwv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hashable" ,ghc-hashable)
+ ("ghc-microlens" ,ghc-microlens)
+ ("ghc-microlens-ghc" ,ghc-microlens-ghc)
+ ("ghc-microlens-mtl" ,ghc-microlens-mtl)
+ ("ghc-microlens-th" ,ghc-microlens-th)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)))
+ (home-page "https://github.com/monadfix/microlens")
+ (synopsis "Feature-complete microlens")
+ (description
+ "This package exports a module which is the recommended starting point
+for using @uref{http://hackage.haskell.org/package/microlens, microlens} if
+you aren't trying to keep your dependencies minimal. By importing
+@code{Lens.Micro.Platform} you get all functions and instances from
+@uref{http://hackage.haskell.org/package/microlens, microlens},
+@uref{http://hackage.haskell.org/package/microlens-th, microlens-th},
+@uref{http://hackage.haskell.org/package/microlens-mtl, microlens-mtl},
+@uref{http://hackage.haskell.org/package/microlens-ghc, microlens-ghc}, as
+well as instances for @code{Vector}, @code{Text}, and @code{HashMap}. The
+minor and major versions of @code{microlens-platform} are incremented whenever
+the minor and major versions of any other @code{microlens} package are
+incremented, so you can depend on the exact version of
+@code{microlens-platform} without specifying the version of @code{microlens}
+you need. This package is a part of the
+@uref{http://hackage.haskell.org/package/microlens, microlens} family; see the
+readme @uref{https://github.com/aelve/microlens#readme, on Github}.")
+ (license license:bsd-3)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")