summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:09:23 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit2e6772515055d1e1fb4ad15356be20f61ebea631 (patch)
tree3ca61784b5ec8797de9e8d038243c172f3db7376 /gnu/packages/haskell.scm
parent536b84a8327f46e920c7aacabe4b3f5e8012af1a (diff)
downloadguix-patches-2e6772515055d1e1fb4ad15356be20f61ebea631.tar
guix-patches-2e6772515055d1e1fb4ad15356be20f61ebea631.tar.gz
gnu: Add ghc-th-orphans.
* gnu/packages/haskell.scm (ghc-th-orphans): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d5b0a01148..183033eb87 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5283,6 +5283,34 @@ datatypes reachable from an initial datatype, and passing these names to some
function which generates instances.")
(license bsd-3)))
+(define-public ghc-th-orphans
+ (package
+ (name "ghc-th-orphans")
+ (version "0.13.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "th-orphans/th-orphans-" version ".tar.gz"))
+ (sha256
+ (base32
+ "105y03bxh0a2r69l603i7md17gg1vxs1jj1n40pn5q486lmfxbmx"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-th-lift" ,ghc-th-lift)
+ ("ghc-th-reify-many" ,ghc-th-reify-many)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-generic-deriving" ,ghc-generic-deriving)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "http://hackage.haskell.org/package/th-orphans")
+ (synopsis "Orphan instances for TH datatypes")
+ (description
+ "This package provides orphan instances for Template Haskell datatypes. In particular,
+instances for @code{Ord} and @code{Lift}, as well as a few missing @code{Show}
+and @code{Eq} instances. These instances used to live in the haskell-src-meta
+package, and that's where the version number started.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")