summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:35:24 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit2763952b9cf79c893d26a6a21ee2b260846af081 (patch)
treec5974aed6c5e294805533969ecca2e60de79f7d5 /gnu/packages/haskell.scm
parent76e2fa7529b2444bdb40692b9dbfc89644372ef7 (diff)
downloadguix-patches-2763952b9cf79c893d26a6a21ee2b260846af081.tar
guix-patches-2763952b9cf79c893d26a6a21ee2b260846af081.tar.gz
gnu: Add ghc-cryptonite.
* gnu/packages/haskell.scm (ghc-cryptonite): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cee55d6209..4ad2f8f52c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5869,6 +5869,43 @@ when ASN1 pattern matching is not convenient.")
tasty.")
(license expat)))
+(define-public ghc-cryptonite
+ (package
+ (name "ghc-cryptonite")
+ (version "0.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "cryptonite/cryptonite-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1h22x22lq2m8h456v5j50xm0l25bcm3h1pchsk83br909hjxql4z"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-memory" ,ghc-memory)
+ ("ghc-byteable" ,ghc-byteable)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-kat" ,ghc-tasty-kat)))
+ (home-page "https://github.com/haskell-crypto/cryptonite")
+ (synopsis "Cryptography primitives")
+ (description
+ "This package is a repository of cryptographic primitives for Haskell.
+It strives to be a cryptographic kitchen sink that provides cryptography for
+everyone.
+
+Supported symmetric ciphers: AES, DES, 3DES, Blowfish, Camellia, RC4, Salsa,
+ChaCha; supported hash functions: SHA1, SHA2, SHA3, MD2, MD4, MD5, Keccak,
+Skein, Ripemd, Tiger, Whirlpool, Blake2; MAC: HMAC, Poly1305; assymmetric
+crypto: DSA, RSA, DH, ECDH, ECDSA, ECC, Curve25519, Ed25519; key derivation
+functions: PBKDF2, Scrypt; cryptographic random number generation: system
+entropy, deterministic random generator; data-related features:
+@dfn{anti-forensic information splitter} (AFIS).")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")