summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:34:59 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit76e2fa7529b2444bdb40692b9dbfc89644372ef7 (patch)
treecaf0f0511daf55aa8963dfc470a3785cff04c991 /gnu/packages/haskell.scm
parent9d3c5d3859897fdfa718f7b8673a3557d5f7b028 (diff)
downloadguix-patches-76e2fa7529b2444bdb40692b9dbfc89644372ef7.tar
guix-patches-76e2fa7529b2444bdb40692b9dbfc89644372ef7.tar.gz
gnu: Add ghc-tasty-kat.
* gnu/packages/haskell.scm (ghc-tasty-kat): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 12b3ea6ce6..cee55d6209 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5845,6 +5845,30 @@ supports for high level forms of ASN1 (BER, and DER).")
when ASN1 pattern matching is not convenient.")
(license bsd-3)))
+(define-public ghc-tasty-kat
+ (package
+ (name "ghc-tasty-kat")
+ (version "0.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "tasty-kat/tasty-kat-" version ".tar.gz"))
+ (sha256
+ (base32
+ "14yvlpli6cv6bn3kh8mlfp4x1l6ns4fvmfv6hmj75cvxyzq029d7"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+ (home-page "https://github.com/vincenthz/tasty-kat")
+ (synopsis "Known Answer Tests (KAT) framework for tasty")
+ (description
+ "This package provides a @dfn{Known Answer Tests} (KAT) framework for
+tasty.")
+ (license expat)))
+
(define-public idris
(package
(name "idris")