summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:07:08 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit25b20a9c7a4d4ec59321bdae256ee5ad29ea2f18 (patch)
tree278da3f754622d5c83aad832940a1ae92f29edf5 /gnu/packages/haskell.scm
parent31be270b930d5ef5ed5d7fc55d3b828af5f8937d (diff)
downloadguix-patches-25b20a9c7a4d4ec59321bdae256ee5ad29ea2f18.tar
guix-patches-25b20a9c7a4d4ec59321bdae256ee5ad29ea2f18.tar.gz
gnu: Add ghc-executable-path.
* gnu/packages/haskell.scm (ghc-executable-path): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 170eab5e6b..42423c4c66 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -23,6 +23,7 @@
#:use-module (ice-9 regex)
#:use-module ((guix licenses) #:select (bsd-3
lgpl2.1 lgpl2.1+ gpl2+ gpl3+
+ public-domain
expat))
#:use-module (guix packages)
#:use-module (guix download)
@@ -5133,6 +5134,28 @@ CommonMark, a fully specified variant of Markdown. It includes sources for
libcmark (0.21.0) and does not require prior installation of the C library.")
(license bsd-3)))
+(define-public ghc-executable-path
+ (package
+ (name "ghc-executable-path")
+ (version "0.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "executable-path/executable-path-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1jg58qf19qz93c60ryglcavwdcysz4fd4qn8kpw5im9w9kniawlc"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/executable-path")
+ (synopsis "Find out the full path of the executable")
+ (description
+ "The documentation of @code{System.Environment.getProgName} says that
+\"However, this is hard-to-impossible to implement on some non-Unix OSes, so
+instead, for maximum portability, we just return the leafname of the program
+as invoked.\" This library tries to provide the missing path.")
+ (license public-domain)))
+
(define-public idris
(package
(name "idris")