summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:06:42 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit31be270b930d5ef5ed5d7fc55d3b828af5f8937d (patch)
tree7f52c3ebe3c2baac9e01933f47146f3c3eb5fe71 /gnu/packages/haskell.scm
parent66c480b6c85a5bd710802847b3594b3bba7b80f9 (diff)
downloadguix-patches-31be270b930d5ef5ed5d7fc55d3b828af5f8937d.tar
guix-patches-31be270b930d5ef5ed5d7fc55d3b828af5f8937d.tar.gz
gnu: Add ghc-cmark.
* gnu/packages/haskell.scm (ghc-cmark): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0bf85bf702..170eab5e6b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5108,6 +5108,31 @@ provided, along with a utility for generating new parsers from Kate XML syntax
descriptions.")
(license gpl2+)))
+(define-public ghc-cmark
+ (package
+ (name "ghc-cmark")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "cmark/cmark-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c134qh65viaq4q6pv7bnnr5wchzivg94nv0dj8pc1326sx0dw12"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/jgm/commonmark-hs")
+ (synopsis "Fast, accurate CommonMark (Markdown) parser and renderer")
+ (description
+ "This package provides Haskell bindings for
+@uref{https://github.com/jgm/cmark, libcmark}, the reference parser for
+CommonMark, a fully specified variant of Markdown. It includes sources for
+libcmark (0.21.0) and does not require prior installation of the C library.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")