summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:29:36 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit1c17529fd51ae6946138c8978190976344bc67ab (patch)
tree101ea999e594d6877f30333a0624fb54ac469325 /gnu/packages/haskell.scm
parentb55630a3a81f3d941f47ddb0a4b50cab60123b58 (diff)
downloadguix-patches-1c17529fd51ae6946138c8978190976344bc67ab.tar
guix-patches-1c17529fd51ae6946138c8978190976344bc67ab.tar.gz
gnu: Add ghc-logging-facade.
* gnu/packages/haskell.scm (ghc-logging-facade): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f297a89dd2..74363fc64a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5424,6 +5424,28 @@ resource handling, and fits in the same general solution space as
enumerator/iteratee and pipes." )
(license expat)))
+(define-public ghc-logging-facade
+ (package
+ (name "ghc-logging-facade")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "logging-facade/logging-facade-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0zhdbjyj0j9by19rma9alxysrxnnl3s4kks4zk4bx0dg5xa0264y"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "http://hackage.haskell.org/package/logging-facade")
+ (synopsis "Simple logging abstraction that allows multiple back-ends")
+ (description
+ "This package provides a simple logging abstraction that allows multiple
+back-ends.")
+ (license expat)))
+
(define-public idris
(package
(name "idris")