summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:29:17 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitb55630a3a81f3d941f47ddb0a4b50cab60123b58 (patch)
treed84547cdff1c41577ef773c19d262ff6f508a405 /gnu/packages/haskell.scm
parent1300634bf15f6e1831eb898c016c2e8f61d98732 (diff)
downloadguix-patches-b55630a3a81f3d941f47ddb0a4b50cab60123b58.tar
guix-patches-b55630a3a81f3d941f47ddb0a4b50cab60123b58.tar.gz
gnu: Add ghc-conduit.
* gnu/packages/haskell.scm (ghc-conduit): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 65cc954d5d..f297a89dd2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5390,6 +5390,40 @@ the function @code{aesonQQ} that compile-time converts a string representation
of a JSON value into a @code{Data.Aeson.Value}.")
(license expat)))
+(define-public ghc-conduit
+ (package
+ (name "ghc-conduit")
+ (version "1.2.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "conduit/conduit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0aq6wswd5dkhdmy7sjhd99mldpq33dqpgbdcwpm94ahvckqxs7v5"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-mmorph" ,ghc-mmorph)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-void" ,ghc-void)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-safe" ,ghc-safe)))
+ (home-page "https://github.com/snoyberg/conduit")
+ (synopsis "Streaming data library ")
+ (description
+ "conduit is a solution to the streaming data problem, allowing for
+production, transformation, and consumption of streams of data in constant
+memory. It is an alternative to lazy I/O which guarantees deterministic
+resource handling, and fits in the same general solution space as
+enumerator/iteratee and pipes." )
+ (license expat)))
+
(define-public idris
(package
(name "idris")