summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-07-18 07:23:02 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:50 -0400
commit14e0ae7ff7c30963ec02990f320cc8b15306e847 (patch)
tree4d604a409a343b8f020516c87d7ed9f28763f723 /gnu/packages/haskell.scm
parent37850fb9a0989d80c6e7375dd323b779cb619c16 (diff)
downloadguix-patches-14e0ae7ff7c30963ec02990f320cc8b15306e847.tar
guix-patches-14e0ae7ff7c30963ec02990f320cc8b15306e847.tar.gz
gnu: Add ghc-hasktags.
* gnu/packages/haskell.scm (ghc-hasktags): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1087461dac..bced44579d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11949,6 +11949,36 @@ you need. This package is a part of the
readme @uref{https://github.com/aelve/microlens#readme, on Github}.")
(license license:bsd-3)))
+(define-public ghc-hasktags
+ (package
+ (name "ghc-hasktags")
+ (version "0.71.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/hasktags/hasktags-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1s2k9qrgy1jily96img2pmn7g35mwnnfiw6si3aw32jfhg5zsh1c"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-system-filepath" ,ghc-system-filepath)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)))
+ (native-inputs
+ `(("ghc-json" ,ghc-json)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-microlens-platform" ,ghc-microlens-platform)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://github.com/MarcWeber/hasktags")
+ (synopsis "Make @code{Ctags} and @code{Etags} files for Haskell programs")
+ (description
+ "This package provides a means of generating tag files for Emacs and
+Vim.")
+ (license license:bsd-3)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")