summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:38:03 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:46 -0500
commitff303e4ebf5cc31b1f00ec48a2f377673f67adad (patch)
treed266f4080e262ccc728045233d899d966c20818a /gnu/packages/haskell-xyz.scm
parentcbc6f8618f378ebd2a514e8e0f455ae27b96575b (diff)
downloadguix-patches-ff303e4ebf5cc31b1f00ec48a2f377673f67adad.tar
guix-patches-ff303e4ebf5cc31b1f00ec48a2f377673f67adad.tar.gz
gnu: Add ghc-hslua-module-system.
* gnu/packages/haskell-xyz.scm (ghc-hslua-module-system): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d175f41175..0d9339407e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5220,6 +5220,36 @@ handler built in.")
described in @url{https://www.lua.org/}.")
(license license:expat)))
+(define-public ghc-hslua-module-system
+ (package
+ (name "ghc-hslua-module-system")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hslua-module-system/hslua-module-system-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1m7wz3g5c34pyizqw5mllzhsy2vziddhlbhjfwdvd7nhd3p4v3hh"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-hslua" ,ghc-hslua)
+ ("ghc-temporary" ,ghc-temporary)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+ (home-page "https://github.com/hslua/hslua-module-system")
+ (synopsis "Lua module wrapper around Haskell's System module")
+ (description "This library provides access to system information and
+functionality to Lua scripts via Haskell's @code{System} module. Intended
+usage for this package is to preload it by adding the loader function to
+@code{package.preload}. Note that the Lua @code{package} library must have
+already been loaded before the loader can be added.")
+ (license license:expat)))
+
(define-public ghc-hslua-module-text
(package
(name "ghc-hslua-module-text")