summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:34:00 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:46 -0500
commitcbc6f8618f378ebd2a514e8e0f455ae27b96575b (patch)
tree77c31709b52f109680c074a36a60c880ae6bc625 /gnu/packages/haskell-xyz.scm
parent1cd3333e3406d4e842e93d963fa374aee7c03db7 (diff)
downloadguix-patches-cbc6f8618f378ebd2a514e8e0f455ae27b96575b.tar
guix-patches-cbc6f8618f378ebd2a514e8e0f455ae27b96575b.tar.gz
gnu: Add ghc-aeson-diff.
* gnu/packages/haskell-xyz.scm (ghc-aeson-diff): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 96a0a93f6e..d175f41175 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -202,6 +202,45 @@ for Haskell.")
ghc-aeson.")
(license license:bsd-3)))
+(define-public ghc-aeson-diff
+ (package
+ (name "ghc-aeson-diff")
+ (version "1.1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "aeson-diff/aeson-diff-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01d48pd7d1mb9cd5yxfajln8rmjdjq8ch91s0lav4qw1azv6vp2r"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-edit-distance-vector" ,ghc-edit-distance-vector)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+ ("ghc-glob" ,ghc-glob)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-doctest" ,ghc-doctest)
+ ("hlint" ,hlint)))
+ (home-page "https://github.com/thsutton/aeson-diff")
+ (synopsis "Extract and apply patches to JSON documents")
+ (description "This is a small library for working with changes to JSON
+documents. It includes a library and two command-line executables in the
+style of the @command{diff} and @command{patch} commands available on many
+systems.")
+ (license license:bsd-3)))
+
(define-public ghc-alex
(package
(name "ghc-alex")