summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 01:41:05 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:54 -0500
commitfd33ffa03a58b3a279feeba1643f772bb6272f80 (patch)
treeaabff32bd7ebfa52159bb3a6e7eee97e59284a8e /gnu/packages/haskell-xyz.scm
parentd8b88d74f793e9344858d61e2e2b20f8da0f67e3 (diff)
downloadguix-patches-fd33ffa03a58b3a279feeba1643f772bb6272f80.tar
guix-patches-fd33ffa03a58b3a279feeba1643f772bb6272f80.tar.gz
gnu: Add ghc-diagrams-solve.
* gnu/packages/haskell-xyz.scm (ghc-diagrams-solve): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5a9266c1b8..86b7d23e3b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2864,6 +2864,37 @@ diagrams, an embedded domain-specific language for compositional,
declarative drawing.")
(license license:bsd-3)))
+(define-public ghc-diagrams-solve
+ (package
+ (name "ghc-diagrams-solve")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "diagrams-solve/diagrams-solve-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "17agchqkmj14b17sw50kzxq4hm056g5d8yy0wnqn5w8h1d0my7x4"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (arguments
+ `(#:cabal-revision
+ ("5" "1yl8cs05fzqcz49p601am1ij66m9pa70yamhfxgcvya2pf8nimlf")))
+ (home-page "https://archives.haskell.org/projects.haskell.org/diagrams/")
+ (synopsis "Pure Haskell solver routines used by diagrams")
+ (description "This library provides Pure Haskell solver routines for
+use by the
+@url{https://archives.haskell.org/projects.haskell.org/diagrams/,
+diagrams framework}. It currently includes routines for finding real
+roots of low-degree (@math{n < 5}) polynomials, and solving tridiagonal
+and cyclic tridiagonal linear systems.")
+ (license license:bsd-3)))
+
(define-public ghc-dictionary-sharing
(package
(name "ghc-dictionary-sharing")