summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 01:32:43 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:53 -0500
commitd8b88d74f793e9344858d61e2e2b20f8da0f67e3 (patch)
tree4fab7eee5deecf7079c9003c29d65cd1ed32bb07 /gnu/packages/haskell-xyz.scm
parentf7ca1fa8ae62d79e554980938ccb318bb02dbda9 (diff)
downloadguix-patches-d8b88d74f793e9344858d61e2e2b20f8da0f67e3.tar
guix-patches-d8b88d74f793e9344858d61e2e2b20f8da0f67e3.tar.gz
gnu: Add ghc-active.
* gnu/packages/haskell-xyz.scm (ghc-active): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 30ce638ed8..5a9266c1b8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -129,6 +129,36 @@ of @code{Par} functionality. See the @code{Control.Monad.Par.Class}
module for more details.")
(license license:bsd-3)))
+(define-public ghc-active
+ (package
+ (name "ghc-active")
+ (version "0.2.0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "active/active-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0x3b4ln6csa554qls28wbxvclkbdz3yi60i1m0q5ing0cs16fifz"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-vector" ,ghc-vector)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-semigroupoids" ,ghc-semigroupoids)
+ ("ghc-lens" ,ghc-lens)
+ ("ghc-linear" ,ghc-linear)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://hackage.haskell.org/package/active")
+ (synopsis "Abstractions for animation")
+ (description "This package defines an @code{Active} abstraction for
+time-varying values with finite start and end times. It is used for
+describing animations within the
+@url{https://archives.haskell.org/projects.haskell.org/diagrams/,
+diagrams framework}.")
+ (license license:bsd-3)))
+
(define-public ghc-adjunctions
(package
(name "ghc-adjunctions")