summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 01:28:08 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:53 -0500
commitf7ca1fa8ae62d79e554980938ccb318bb02dbda9 (patch)
treeaee18dccadc45dc3d73b40368d76da9172fa8e74 /gnu/packages/haskell-xyz.scm
parent194a82e6445092ffee1b20b121bab08c52bd419c (diff)
downloadguix-patches-f7ca1fa8ae62d79e554980938ccb318bb02dbda9.tar
guix-patches-f7ca1fa8ae62d79e554980938ccb318bb02dbda9.tar.gz
gnu: Add ghc-intervals.
* gnu/packages/haskell-xyz.scm (ghc-intervals): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d1b5792fde..30ce638ed8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5784,6 +5784,35 @@ search for all keys containing a point or overlapping an interval. See the
example code on the home page for a quick introduction.")
(license license:bsd-3)))
+(define-public ghc-intervals
+ (package
+ (name "ghc-intervals")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "intervals/intervals-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00vyxf3ba9d7aas3npfapr53w71fslgh69fczjb25axr66fvzqww"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-distributive" ,ghc-distributive)))
+ (native-inputs
+ `(("cabal-doctest" ,cabal-doctest)
+ ("ghc-doctest" ,ghc-doctest)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (arguments
+ `(#:cabal-revision
+ ("4" "1qx3q0v13l1zaln9zdk8chxpxhshbz5x0vqm0qda7d1kpv7h6a7r")))
+ (home-page "https://github.com/ekmett/intervals")
+ (synopsis "Interval arithmetic")
+ (description "This library provides
+@code{Numeric.Interval.Interval}, which represets a closed, convex set
+of floating point values.")
+ (license license:bsd-3)))
+
(define-public ghc-invariant
(package
(name "ghc-invariant")