summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 01:24:09 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:53 -0500
commit194a82e6445092ffee1b20b121bab08c52bd419c (patch)
tree827c3632851332ed7b398a66389e5e238d991b8d /gnu/packages/haskell-xyz.scm
parent1859c94aa1ef05d325732197f764af6205efc137 (diff)
downloadguix-patches-194a82e6445092ffee1b20b121bab08c52bd419c.tar
guix-patches-194a82e6445092ffee1b20b121bab08c52bd419c.tar.gz
gnu: Add ghc-numeric-extras.
* gnu/packages/haskell-xyz.scm (ghc-numeric-extras): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2aec9602fe..d1b5792fde 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7578,6 +7578,26 @@ class, and a lazy number type for non-negative numbers (a generalization
of Peano numbers).")
(license license:gpl3+)))
+(define-public ghc-numeric-extras
+ (package
+ (name "ghc-numeric-extras")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "numeric-extras/numeric-extras-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1mk11c0gz1yjy5b8dvq6czfny57pln0bs7x28fz38qyr44872067"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/ekmett/numeric-extras")
+ (synopsis "Useful tools from the C standard library")
+ (description "This library provides some useful tools from the C
+standard library.")
+ (license license:bsd-3)))
+
(define-public ghc-objectname
(package
(name "ghc-objectname")