summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:22:46 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:45 -0500
commite71fb57349109ec42207afe139153e578c43cd99 (patch)
treeb24b8ba12797a08c2af578fe63af76adc4d49c40 /gnu/packages/haskell-xyz.scm
parent3ebae41f5a15d7d7b9356885830c47e4e1ecb54b (diff)
downloadguix-patches-e71fb57349109ec42207afe139153e578c43cd99.tar
guix-patches-e71fb57349109ec42207afe139153e578c43cd99.tar.gz
gnu: Add ghc-getopt-generics.
* gnu/packages/haskell-xyz.scm (ghc-getopt-generics): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 700dc9c8a2..ba6bd3ea19 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4019,6 +4019,37 @@ with the @code{Validity} typeclass.")
properties for functions operating on them.")
(license license:expat)))
+(define-public ghc-getopt-generics
+ (package
+ (name "ghc-getopt-generics")
+ (version "0.13.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "getopt-generics/getopt-generics-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rszkcn1rg38wf35538ljk5bbqjc57y9sb3a0al7qxm82gy8yigr"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-base-orphans" ,ghc-base-orphans)
+ ("ghc-generics-sop" ,ghc-generics-sop)
+ ("ghc-tagged" ,ghc-tagged)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-silently" ,ghc-silently)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/soenkehahn/getopt-generics")
+ (synopsis "Create command line interfaces with ease")
+ (description "This library provides tools to create command line
+interfaces with ease.")
+ (license license:bsd-3)))
+
(define-public ghc-gitrev
(package
(name "ghc-gitrev")