summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:18:35 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:45 -0500
commit3ebae41f5a15d7d7b9356885830c47e4e1ecb54b (patch)
treed89958535bbd2da5c51c15a070587662ae3b8e2c /gnu/packages/haskell-xyz.scm
parent64f4278624eb863059f4e9ac93bca37cb39b8fae (diff)
downloadguix-patches-3ebae41f5a15d7d7b9356885830c47e4e1ecb54b.tar
guix-patches-3ebae41f5a15d7d7b9356885830c47e4e1ecb54b.tar.gz
gnu: Add ghc-edit-distance-vector.
* gnu/packages/haskell-xyz.scm (ghc-edit-distance-vector): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 882df583d1..700dc9c8a2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3034,6 +3034,39 @@ distances for fuzzy matching, including Levenshtein and restricted
Damerau-Levenshtein algorithms.")
(license license:bsd-3)))
+(define-public ghc-edit-distance-vector
+ (package
+ (name "ghc-edit-distance-vector")
+ (version "1.0.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "edit-distance-vector/edit-distance-vector-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "07qgc8dyi9kkzkd3xcd78wdlljy0xwhz65b4r2qg2piidpcdvpxp"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)))
+ (home-page "https://github.com/thsutton/edit-distance-vector")
+ (synopsis "Calculate edit distances and edit scripts between vectors")
+ (description "This package provides implementation of the
+Wagner-Fischer dynamic programming algorithm to find the optimal edit
+script and cost between two sequences. The implementation in this
+package is specialised to sequences represented with @code{Data.Vector}
+but is otherwise agnostic to:
+@itemize
+@item The type of values in the vectors;
+@item The type representing edit operations; and
+@item The type representing the cost of operations.
+@end itemize")
+ (license license:bsd-3)) )
+
(define-public ghc-either
(package
(name "ghc-either")