summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:30:45 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:45 -0500
commit1cd3333e3406d4e842e93d963fa374aee7c03db7 (patch)
treefec5aec51c88957390e97af6ec0c91c77f7656ad /gnu/packages/haskell-xyz.scm
parentfac520bfa85d00563c3473ad42fbadb8c6ecf2c5 (diff)
downloadguix-patches-1cd3333e3406d4e842e93d963fa374aee7c03db7.tar
guix-patches-1cd3333e3406d4e842e93d963fa374aee7c03db7.tar.gz
gnu: Add ghc-microlens-aeson.
* gnu/packages/haskell-xyz.scm (ghc-microlens-aeson): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 10d51f18ac..96a0a93f6e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6480,6 +6480,37 @@ combinators (like @code{failing} and @code{singular}), but everything else is
stripped. As the result, this package has no dependencies.")
(license license:bsd-3)))
+(define-public ghc-microlens-aeson
+ (package
+ (name "ghc-microlens-aeson")
+ (version "2.3.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "microlens-aeson/microlens-aeson-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0w630kk5bnily1qh41081gqgbwmslrh5ad21899gwnb2r3jripyw"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-microlens" ,ghc-microlens)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+ (home-page "https://github.com/fosskers/microlens-aeson")
+ (synopsis "Law-abiding lenses for Aeson, using microlens")
+ (description "This library provides law-abiding lenses for Aeson, using
+microlens.")
+ (license license:expat)))
+
(define-public ghc-microlens-ghc
(package
(name "ghc-microlens-ghc")