summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 00:42:50 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:53 -0500
commit577a78b779fe31057107d32dbb78905cb54780e5 (patch)
treea7b7142fb1993f43c1bc1fe8fc734e3b995b5304 /gnu/packages/haskell-xyz.scm
parent471e77cffa1cc6d10f54c4bd322a7d8eb23901f2 (diff)
downloadguix-patches-577a78b779fe31057107d32dbb78905cb54780e5.tar
guix-patches-577a78b779fe31057107d32dbb78905cb54780e5.tar.gz
gnu: Add ghc-dual-tree.
* gnu/packages/haskell-xyz.scm (ghc-dual-tree): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0b32de78ce..0594c5ea6f 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3017,6 +3017,35 @@ It is modeled after doctest for Python, see
between double precision floating point and text.")
(license license:bsd-3)))
+(define-public ghc-dual-tree
+ (package
+ (name "ghc-dual-tree")
+ (version "0.2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "dual-tree/dual-tree-" version ".tar.gz"))
+ (sha256
+ (base32
+ "17kdfnf0df0z5pkiifxrlmyd1xd7hjjaazd2kzyajl0gd00vbszx"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-newtype-generics" ,ghc-newtype-generics)
+ ("ghc-monoid-extras" ,ghc-monoid-extras)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-testing-feat" ,ghc-testing-feat)))
+ (home-page "https://hackage.haskell.org/package/dual-tree")
+ (synopsis "Rose trees with cached and accumulating monoidal annotations")
+ (description "Rose (@math{n}-ary) trees with both upwards- (i.e.
+cached) and downwards-traveling (i.e. accumulating) monoidal
+annotations. This is used as the core data structure underlying the
+@url{https://archives.haskell.org/projects.haskell.org/diagrams/,
+diagrams framework}, but potentially has other applications as well.")
+ (license license:bsd-3)))
+
(define-public ghc-easy-file
(package
(name "ghc-easy-file")