summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 00:38:48 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:52 -0500
commit471e77cffa1cc6d10f54c4bd322a7d8eb23901f2 (patch)
tree10ce549a27546b997c0e6a84614b5498d88f402b /gnu/packages/haskell-xyz.scm
parentf3e18645e0e344178761ce28ca5c55ac25abc232 (diff)
downloadguix-patches-471e77cffa1cc6d10f54c4bd322a7d8eb23901f2.tar
guix-patches-471e77cffa1cc6d10f54c4bd322a7d8eb23901f2.tar.gz
gnu: Add ghc-monoid-extras.
* gnu/packages/haskell-xyz.scm (ghc-monoid-extras): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 63ec19f88a..0b32de78ce 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7185,6 +7185,34 @@ you are used to, it adds on an IsSequence typeclass and has code for marking
data structures as non-empty.")
(license license:expat)))
+(define-public ghc-monoid-extras
+ (package
+ (name "ghc-monoid-extras")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "monoid-extras/monoid-extras-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xfrkgqn9d31z54l617m3w3kkd5m9vjb4yl247r3zzql3mpb1f37"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-groups" ,ghc-groups)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-semigroupoids" ,ghc-semigroupoids)))
+ (arguments
+ `(#:cabal-revision
+ ("1" "0b8x5d6vh7mpigvjvcd8f38a1nyzn1vfdqypslw7z9fgsr742913")))
+ (home-page "https://hackage.haskell.org/package/monoid-extras")
+ (synopsis "Various extra monoid-related definitions and utilities")
+ (description "This package provides various extra monoid-related
+definitions and utilities, such as monoid actions, monoid coproducts,
+semi-direct products, \"deletable\" monoids, \"split\" monoids, and
+\"cut\" monoids.")
+ (license license:bsd-3)))
+
(define-public ghc-murmur-hash
(package
(name "ghc-murmur-hash")