summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 00:45:31 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:53 -0500
commit1859c94aa1ef05d325732197f764af6205efc137 (patch)
tree0547555c1bfe81a7fa407c136bde423eb9ed686d /gnu/packages/haskell-xyz.scm
parent577a78b779fe31057107d32dbb78905cb54780e5 (diff)
downloadguix-patches-1859c94aa1ef05d325732197f764af6205efc137.tar
guix-patches-1859c94aa1ef05d325732197f764af6205efc137.tar.gz
gnu: Add ghc-diagrams-core.
* gnu/packages/haskell-xyz.scm (ghc-diagrams-core): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0594c5ea6f..2aec9602fe 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2804,6 +2804,36 @@ related modules split from the statistics library.")
and parsers with useful semantics.")
(license license:bsd-3)))
+(define-public ghc-diagrams-core
+ (package
+ (name "ghc-diagrams-core")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "diagrams-core/diagrams-core-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0qgb43vy23g4fxh3nmxfq6jyp34imqvkhgflaa6rz0iq6d60gl43"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-monoid-extras" ,ghc-monoid-extras)
+ ("ghc-dual-tree" ,ghc-dual-tree)
+ ("ghc-lens" ,ghc-lens)
+ ("ghc-linear" ,ghc-linear)
+ ("ghc-adjunctions" ,ghc-adjunctions)
+ ("ghc-distributive" ,ghc-distributive)
+ ("ghc-profunctors" ,ghc-profunctors)))
+ (home-page "https://archives.haskell.org/projects.haskell.org/diagrams/")
+ (synopsis "Core libraries for diagrams embedded domain-specific language")
+ (description "This package provides the core modules underlying
+diagrams, an embedded domain-specific language for compositional,
+declarative drawing.")
+ (license license:bsd-3)))
+
(define-public ghc-dictionary-sharing
(package
(name "ghc-dictionary-sharing")