summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-11-03 17:02:50 -0500
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2020-11-04 12:03:53 -0500
commit161e1019fd2110e130082f7bf24a6ab1dbab5dcf (patch)
tree69e2c8092a94ec75c9018e3a6bdc832f1943d15d /gnu/packages/haskell-xyz.scm
parentc00d001d79417b6e62953caf9c3fee9c7ae8ba29 (diff)
downloadguix-patches-161e1019fd2110e130082f7bf24a6ab1dbab5dcf.tar
guix-patches-161e1019fd2110e130082f7bf24a6ab1dbab5dcf.tar.gz
gnu: Add ghc-network-multicast.
* gnu/packages/haskell-xyz.scm (ghc-network-multicast): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7596334316..19eabd949b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8588,6 +8588,36 @@ getting a list of all the network interfaces and their respective
IPv4, IPv6 and MAC addresses.")
(license license:bsd-3)))
+(define-public ghc-network-multicast
+ (package
+ (name "ghc-network-multicast")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/network-multicast/network-multicast-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0whvi0pbwjy6dbwfdf9rv1j3yr3lcmfp3q7a8pwq63g537l4l2l3"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-network" ,ghc-network)
+ ("ghc-network-bsd" ,ghc-network-bsd)))
+ (home-page
+ "http://hackage.haskell.org/package/network-multicast")
+ (synopsis "Simple multicast library for Haskell")
+ (description
+ "This package provides the Network.Multicast Haskell module for
+sending UDP datagrams over multicast (class D) addresses.")
+ ;; Note that this is technically under CC0 1.0 and Expat, though it's not
+ ;; totally clear what the breakdown is. Since CC0 1.0 is effectively
+ ;; "public domain with a minimal fallback license", figuring marking it
+ ;; as effectively Expat is probably correct.
+ (license license:expat)))
+
(define-public ghc-network-uri
(package
(name "ghc-network-uri")