summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-11-03 17:00:02 -0500
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2020-11-04 12:03:53 -0500
commitc00d001d79417b6e62953caf9c3fee9c7ae8ba29 (patch)
treee24b0fc96731be1a2c6454e51641be9047488729 /gnu/packages/haskell-xyz.scm
parent04d8f94cf1f3c50ad313906c35669c8858e6c49d (diff)
downloadguix-patches-c00d001d79417b6e62953caf9c3fee9c7ae8ba29.tar
guix-patches-c00d001d79417b6e62953caf9c3fee9c7ae8ba29.tar.gz
gnu: Add ghc-mountpoints.
* gnu/packages/haskell-xyz.scm (ghc-mountpoints): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 43dc7d5bbf..7596334316 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
+;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8306,6 +8307,28 @@ semi-direct products, \"deletable\" monoids, \"split\" monoids, and
\"cut\" monoids.")
(license license:bsd-3)))
+(define-public ghc-mountpoints
+ (package
+ (name "ghc-mountpoints")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/mountpoints/mountpoints-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1hnm31pqcffphyc463wf0vbik9fzm5lb2r4wjdc1y4dqzmjdzz37"))))
+ (build-system haskell-build-system)
+ (home-page
+ "http://hackage.haskell.org/package/mountpoints")
+ (synopsis "Haskell library for listing mount points")
+ (description "This library provides Haskell bindings for checking
+currently mounted filesystems.")
+ (license license:lgpl2.1+)))
+
(define-public ghc-mtl-compat
(package
(name "ghc-mtl-compat")