summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:45:59 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:26 +0100
commite345d93825976c16f0b5efce72d3b46140c8cf48 (patch)
treebacfb198c29427d48ecd4af2047d53b517d1a0b8 /gnu/packages/haskell-web.scm
parent03d4ea83bfe6d38622ecaba6c6c56da1c2d211b1 (diff)
downloadguix-patches-e345d93825976c16f0b5efce72d3b46140c8cf48.tar
guix-patches-e345d93825976c16f0b5efce72d3b46140c8cf48.tar.gz
gnu: Add ghc-aeson-better-errors.
* gnu/packages/haskell-web.scm (ghc-aeson-better-errors): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index aae1209218..4689025432 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1005,6 +1005,39 @@ the function @code{aesonQQ} that compile-time converts a string representation
of a JSON value into a @code{Data.Aeson.Value}.")
(license license:expat)))
+(define-public ghc-aeson-better-errors
+ (package
+ (name "ghc-aeson-better-errors")
+ (version "0.9.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/aeson-better-errors/aeson-better-errors-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "09vkyrhwak3bmpfsqcd2az8hfqqkxyhg468hv5avgisy0nzh3w38"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-dlist" ,ghc-dlist)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-void" ,ghc-void)))
+ (home-page
+ "https://github.com/hdgarrood/aeson-better-errors")
+ (synopsis
+ "Better error messages when decoding JSON values in Haskell")
+ (description
+ "Gives you the tools to build parsers to decode JSON values, and gives
+good error messages when parsing fails. See also
+@url{http://harry.garrood.me/blog/aeson-better-errors/}.")
+ (license license:expat)))
+
(define-public ghc-multipart
(package
(name "ghc-multipart")