summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:44:47 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:26 +0100
commit03d4ea83bfe6d38622ecaba6c6c56da1c2d211b1 (patch)
tree8672d5a5dbe463a54d51e5241e97aa504c97ec9e /gnu/packages/haskell-web.scm
parent42e712867332ab421b3d38e67ca4b5dbba3e8061 (diff)
downloadguix-patches-03d4ea83bfe6d38622ecaba6c6c56da1c2d211b1.tar
guix-patches-03d4ea83bfe6d38622ecaba6c6c56da1c2d211b1.tar.gz
gnu: Add ghc-bower-json.
* gnu/packages/haskell-web.scm (ghc-bower-json): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 314e5b1e1b..aae1209218 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1840,3 +1840,34 @@ proposed by Google and Mozilla here
"Parses Javascript into an Abstract Syntax Tree (AST). Initially intended
as frontend to hjsmin.")
(license license:bsd-3)))
+
+(define-public ghc-bower-json
+ (package
+ (name "ghc-bower-json")
+ (version "1.0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/bower-json/bower-json-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0wvygg3rdbxzrmr61a9w6ddv9pfric85ih8hnxyk0ydzn7i59abs"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-aeson-better-errors" ,ghc-aeson-better-errors)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-transformers" ,ghc-transformers)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+ (home-page "https://github.com/hdgarrood/bower-json")
+ (synopsis "Read bower.json from Haskell")
+ (description
+ "This package provides a data type and ToJSON/FromJSON instances for
+Bower's package manifest file, bower.json.")
+ (license license:expat)))