summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:39:09 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:25 +0100
commit868415d8a408f027eb4ed3e23b655c5302774e93 (patch)
treeae9de3078d2fd3892b205f61bf6f6a59920f98b0 /gnu/packages/haskell-web.scm
parentb62f4ec4ca130a31575f5e5112a49e8665dc7c81 (diff)
downloadguix-patches-868415d8a408f027eb4ed3e23b655c5302774e93.tar
guix-patches-868415d8a408f027eb4ed3e23b655c5302774e93.tar.gz
gnu: Add ghc-sourcemap.
gnu/pacakges/haskell-web.scm (ghc-sourcemap): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 089df39ea6..39ffe0f8d5 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1774,3 +1774,37 @@ non-Haskell dependencies.")
and Perl's @code{Web::Scraper}. Scalpel builds on top of TagSoup to provide a
declarative and monadic interface.")
(license license:asl2.0)))
+
+(define-public ghc-sourcemap
+ (package
+ (name "ghc-sourcemap")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/sourcemap/sourcemap-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0ynfm44ym8y592wnzdwa0d05dbkffyyg5sm26y5ylzpynk64r85r"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (arguments
+ `(#:tests? #f ; FIXME: Fail to compile
+ #:cabal-revision
+ ("1" "1f7q44ar6qfip8fsllg43jyn7r15ifn2r0vz32cbmx0sb0d38dax")))
+ (home-page
+ "http://hackage.haskell.org/package/sourcemap")
+ (synopsis
+ "Implementation of source maps as proposed by Google and Mozilla")
+ (description
+ "Sourcemap provides an implementation of source maps, revision 3,
+proposed by Google and Mozilla here
+@url{https://wiki.mozilla.org/DevTools/Features/SourceMap}.")
+ (license license:bsd-3)))