summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:37:29 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:25 +0100
commitb62f4ec4ca130a31575f5e5112a49e8665dc7c81 (patch)
tree4ffc37ce7c36e35f0953304813933cc1447f4f74 /gnu/packages/haskell-web.scm
parentc9fc2d2964f9932d355cefdfec5886e28cb94600 (diff)
downloadguix-patches-b62f4ec4ca130a31575f5e5112a49e8665dc7c81.tar
guix-patches-b62f4ec4ca130a31575f5e5112a49e8665dc7c81.tar.gz
gnu: Add ghc-wai-websockets.
* gnu/packages/haskell-web.scm (ghc-wai-websockets): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 09ed793323..089df39ea6 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -706,6 +706,36 @@ See also:
@end itemize")
(license license:bsd-3)))
+(define-public ghc-wai-websockets
+ (package
+ (name "ghc-wai-websockets")
+ (version "3.0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/wai-websockets/wai-websockets-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0b2xmdsrsqpssyib53wbr6r8hf75789ndyyanv37sv99iyqcwz4i"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-wai" ,ghc-wai)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-network" ,ghc-network)
+ ("ghc-websockets" ,ghc-websockets)
+ ("ghc-http-types" ,ghc-http-types)))
+ (arguments
+ `(#:configure-flags '("--flags=-example")))
+ (home-page "https://github.com/yesodweb/wai")
+ (synopsis
+ "Provide a bridge between WAI and the websockets package")
+ (description
+ "Use websockets with WAI applications, primarily those hosted via Warp.")
+ (license license:expat)))
+
(define-public ghc-xss-sanitize
(package
(name "ghc-xss-sanitize")