summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-07 18:01:54 -0700
committerTimothy Sample <samplet@ngyro.com>2019-09-02 23:09:39 -0400
commit5b0fdbba8ad5b539f017187e065e22245a442cf9 (patch)
tree576da6a0c6b8a74afe6b729145d2452a7fb6af9d /gnu/packages/haskell-web.scm
parent621c077384c9dba6955bf712c7c93e7c0f3304f1 (diff)
downloadguix-patches-5b0fdbba8ad5b539f017187e065e22245a442cf9.tar
guix-patches-5b0fdbba8ad5b539f017187e065e22245a442cf9.tar.gz
gnu: Add ghc-js-flot.
* gnu/packages/haskell-web.scm (ghc-js-flot): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 169d858a0b..6f1c460eaa 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1490,3 +1490,30 @@ version number match the upstream jQuery version. The package is
designed to meet the redistribution requirements of downstream
users (e.g. Debian).")
(license license:expat)))
+
+(define-public ghc-js-flot
+ (package
+ (name "ghc-js-flot")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://hackage.haskell.org/package/js-flot/js-flot-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0yjyzqh3qzhy5h3nql1fckw0gcfb0f4wj9pm85nafpfqp2kg58hv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-http" ,ghc-http)))
+ (home-page "https://github.com/ndmitchell/js-flot")
+ (synopsis "Obtain minified flot code")
+ (description "This package bundles the minified
+@url{http://www.flotcharts.org/, Flot} code (a jQuery plotting library)
+into a Haskell package, so it can be depended upon by Cabal packages.
+The first three components of the version number match the upstream flot
+version. The package is designed to meet the redistribution
+requirements of downstream users (e.g. Debian).")
+ (license license:expat)))