summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-07 18:00:52 -0700
committerTimothy Sample <samplet@ngyro.com>2019-09-02 23:09:39 -0400
commit621c077384c9dba6955bf712c7c93e7c0f3304f1 (patch)
tree60271120b8851bbd9fe9944e2c360280637aa01c /gnu/packages/haskell-web.scm
parent21f5b9a9b9a8d30aeeb686febbf59a88a97f4c1b (diff)
downloadguix-patches-621c077384c9dba6955bf712c7c93e7c0f3304f1.tar
guix-patches-621c077384c9dba6955bf712c7c93e7c0f3304f1.tar.gz
gnu: Add ghc-js-jquery.
* gnu/packages/haskell-web.scm (ghc-js-jquery): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 7cbf8932e6..169d858a0b 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1463,3 +1464,29 @@ Together with the snap-core library upon which it depends, it provides a
clean and efficient Haskell programming interface to the HTTP
protocol.")
(license license:bsd-3)))
+
+(define-public ghc-js-jquery
+ (package
+ (name "ghc-js-jquery")
+ (version "3.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://hackage.haskell.org/package/js-jquery/js-jquery-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "16q68jzbs7kp07dnq8cprdcc8fd41rim38039vg0w4x11lgniq70"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; tests do network IO
+ (home-page "https://github.com/ndmitchell/js-jquery")
+ (synopsis "Obtain minified jQuery code")
+ (description "This package bundles the minified
+@url{http://jquery.com/, jQuery} code into a Haskell package, so it can
+be depended upon by Cabal packages. The first three components of the
+version number match the upstream jQuery version. The package is
+designed to meet the redistribution requirements of downstream
+users (e.g. Debian).")
+ (license license:expat)))