summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-22 09:46:06 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:21 +0200
commit5a88cff239c238ba04b7ec45fae66aae077a0958 (patch)
treeb68de83f9c369e4fe836003f9f44f0b3b217f046 /gnu/packages/haskell-crypto.scm
parentbf7e5884321ee4f4c4f3c83a647b92817b511453 (diff)
downloadguix-patches-5a88cff239c238ba04b7ec45fae66aae077a0958.tar
guix-patches-5a88cff239c238ba04b7ec45fae66aae077a0958.tar.gz
ghc: Add ghc-ed25519.
* gnu/packages/haskell-crypto.scm (ghc-ed25519): New variable.
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 0d9617e03d..9bdcdb2f9e 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -701,3 +701,33 @@ percent.
@item Monte Carlo value for Pi is 3.132465868 (error 0.29 percent).
@end itemize")
(license license:bsd-3)))
+
+(define-public ghc-ed25519
+ (package
+ (name "ghc-ed25519")
+ (version "0.0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/ed25519/ed25519-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0v8msqvgzimhs7p5ri25hrb1ni2wvisl5rmdxy89fc59py79b9fq"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("2" "1cq6h3jqkb1kvd9fjfhsllg5gq78sdiyf2gy9862xhlbv6wil19f")
+ ;; We omit these test suites because they require old versions of
+ ;; packages and packages we do not have.
+ #:configure-flags
+ '("--flags=-test-hlint -test-doctests -test-properties")))
+ (home-page "http://thoughtpolice.github.com/hs-ed25519")
+ (synopsis "Ed25519 cryptographic signatures")
+ (description "This package provides a simple, fast, self-contained
+copy of the Ed25519 public-key signature system with a clean interface.
+It also includes support for detached signatures, and thorough
+documentation on the design and implementation, including usage
+guidelines.")
+ (license license:expat)))