summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-22 09:43:20 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:21 +0200
commitbf7e5884321ee4f4c4f3c83a647b92817b511453 (patch)
tree77fec09418e859ab24def6b12bfe617080276478 /gnu/packages/haskell-crypto.scm
parentc4a68deaad5e32894f881035613c2cdaedf9f61a (diff)
downloadguix-patches-bf7e5884321ee4f4c4f3c83a647b92817b511453.tar
guix-patches-bf7e5884321ee4f4c4f3c83a647b92817b511453.tar.gz
gnu: Add ghc-cryptohash-sha256.
* gnu/packages/haskell-crypto.scm (ghc-cryptohash-sha256): New variable.
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index ff44970be0..0d9617e03d 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -257,6 +257,42 @@ The implementation is made in C with a haskell FFI wrapper that hides
the C implementation.")
(license license:bsd-3)))
+(define-public ghc-cryptohash-sha256
+ (package
+ (name "ghc-cryptohash-sha256")
+ (version "0.11.101.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "cryptohash-sha256-" version "/"
+ "cryptohash-sha256-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1p85vajcgw9hmq8zsz9krzx0vxh7aggwbg5w9ws8w97avcsn8xaj"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("1" "19birnmwga1yh82l4jqc3fygqkqcf5y8dlldnxfswngkzc3rvwp3")
+ #:tests? #f)) ; tests require old version of ghc-hunit (0.9)
+ (inputs
+ `(("ghc-base16-bytestring" ,ghc-base16-bytestring)))
+ (native-inputs
+ `(("ghc-sha" ,ghc-sha)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/hvr/cryptohash-sha1")
+ (synopsis "SHA-256 implementation for Haskell")
+ (description "This Haskell package provides an incremental and
+one-pass, pure API to the @uref{https://en.wikipedia.org/wiki/SHA-2,
+SHA-256 cryptographic hash algorithm}, with performance close to the
+fastest implementations available in other languages.
+
+The implementation is made in C with a haskell FFI wrapper that hides
+the C implementation.")
+ (license license:bsd-3)))
+
(define-public ghc-cryptonite
(package
(name "ghc-cryptonite")