summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 21:13:54 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:32 -0500
commit5e2d41f467a605befd5e689e578a1ef2a81f4f7a (patch)
treeda3fbec4e53c67d96826d8f3facbd57f6df52f68 /gnu/packages/haskell-check.scm
parentcb71ac3d34020b066f959bca0cac6e22b1f54a6c (diff)
downloadguix-patches-5e2d41f467a605befd5e689e578a1ef2a81f4f7a.tar
guix-patches-5e2d41f467a605befd5e689e578a1ef2a81f4f7a.tar.gz
gnu: Add ghc-tasty-hedgehog.
* gnu/packages/haskell-check.scm (ghc-tasty-hedgehog): New variable.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 0537fb91df..8fac25a6d0 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -184,6 +184,36 @@ you combine your unit tests, golden tests, QuickCheck/SmallCheck properties,
and any other types of tests into a single test suite.")
(license license:expat)))
+(define-public ghc-tasty-hedgehog
+ (package
+ (name "ghc-tasty-hedgehog")
+ (version "1.0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "tasty-hedgehog/tasty-hedgehog-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mbg5q0c0xfrk4npfj60pi693igb7r5l78x6xf9fk2jglw0nmxhz"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-tagged" ,ghc-tagged)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-hedgehog" ,ghc-hedgehog)))
+ (native-inputs
+ `(("ghc-tasty-expected-failure" ,ghc-tasty-expected-failure)))
+ (arguments
+ `(#:cabal-revision
+ ("1" "1n6797fm8swyrk8cw7zxz593gq82wx8dayvm204rmgcz75bslcpn")))
+ (home-page "https://github.com/qfpl/tasty-hedgehog")
+ (synopsis "Integration for tasty and hedgehog")
+ (description "This package provides the means for integrating the
+@url{https://hackage.haskell.org/package/hedgehog, hedgehog testing library}
+with the @url{https://hackage.haskell.org/package/tasty, tasty testing
+framework}.")
+ (license license:bsd-3)))
+
(define-public ghc-tasty-hunit
(package
(name "ghc-tasty-hunit")