summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 14:24:13 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:32 -0500
commitcb71ac3d34020b066f959bca0cac6e22b1f54a6c (patch)
tree5a16b3740344d251683926c9bebb687252743b67 /gnu/packages/haskell-check.scm
parent59ea213790f6703b66fee6094b3558b9bb5740fa (diff)
downloadguix-patches-cb71ac3d34020b066f959bca0cac6e22b1f54a6c.tar
guix-patches-cb71ac3d34020b066f959bca0cac6e22b1f54a6c.tar.gz
gnu: ghc-hedgehog: Update to 1.0.1.
* gnu/packages/haskell-check.scm (ghc-hedgehog): Update to 1.0.1. [inputs]: Add 'ghc-fail'.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index ea7f30e680..0537fb91df 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -795,7 +795,7 @@ implementations of cryptographic ciphers.")
(define-public ghc-hedgehog
(package
(name "ghc-hedgehog")
- (version "0.6.1")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
@@ -805,13 +805,14 @@ implementations of cryptographic ciphers.")
".tar.gz"))
(sha256
(base32
- "0xz10ycdm5vk9nrcym1fi83k19frfwqz18bz8bnpzwvaj0j41yfj"))))
+ "1qc7hkqbnsk3f5r26wc35r3qiy941nmcxhfqgcq9027kw4gs0bi0"))))
(build-system haskell-build-system)
(inputs
`(("ghc-ansi-terminal" ,ghc-ansi-terminal)
("ghc-async" ,ghc-async)
("ghc-concurrent-output" ,ghc-concurrent-output)
("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-fail" ,ghc-fail)
("ghc-lifted-async" ,ghc-lifted-async)
("ghc-mmorph" ,ghc-mmorph)
("ghc-monad-control" ,ghc-monad-control)