summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-11 12:29:32 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:10:04 +0200
commit5c57328ef739a2dc5a2cf2143e02f9a1581e2b22 (patch)
tree53d8eec3169082896b8c8b6dd1929a63a20a96f5 /gnu/packages/gtk.scm
parent20842b795e25273a5d75d5ee7e584cb12f5f8125 (diff)
downloadguix-patches-5c57328ef739a2dc5a2cf2143e02f9a1581e2b22.tar
guix-patches-5c57328ef739a2dc5a2cf2143e02f9a1581e2b22.tar.gz
gnu: Add libthai.
* gnu/packages/gtk.scm (libthai): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 83a7490208..42fa91254d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -254,6 +254,38 @@ representing trie. Trie is a kind of digital search tree.")
(home-page "https://linux.thai.net/~thep/datrie/datrie.html")
(license license:lgpl2.1+)))
+(define-public libthai
+ (package
+ (name "libthai")
+ (version "0.1.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://linux.thai.net/pub/thailinux/software/"
+ "libthai/libthai-" version ".tar.xz"))
+ (sha256
+ (base32 "04g93bgxrcnay9fglpq2lj9nr7x1xh06i60m7haip8as9dxs3q7z"))))
+ (build-system gnu-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append "--with-html-docdir="
+ (assoc-ref %outputs "doc")
+ "/share/doc/libthai/html"))))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("datrie" ,libdatrie)))
+ (synopsis "Thai language support library")
+ (description "LibThai is a set of Thai language support routines aimed to
+ease developers’ tasks to incorporate Thai language support in their
+applications.")
+ (home-page "https://linux.thai.net/projects/libthai")
+ (license license:lgpl2.1+)))
+
(define-public pango
(package
(name "pango")